Piment Noir Wiki

Example configuration

The LAN is considered DHCP powered and the TP-Link is OpenWRT powered.
This configuration is for two tagged VLANs to isolate two SSIDs.

--- 8< --- /etc/config/network
...
config interface 'lan'                                                                               
        option ifname 'eth0'                                                                                                                                 
        option proto 'dhcp'                                                                                                                                  
        option hostname 'tp-link-coworkers'                                                                                                              
                                                                                                                                                             
config interface 'vlan101'                                                                                                                                   
        option type 'bridge'                                                                                                                                 
        option _orig_ifname 'eth0.101'                                                                                                                       
        option _orig_bridge 'true'                                                                                                                           
        option proto 'dhcp'                                                                                                                                  
        option ifname 'eth0.101'                                                                                                                             
                                                                                                                                                             
config interface 'vlan102'                                                                                                                                   
        option type 'bridge'                                                                                                                                 
        option _orig_ifname 'eth0.102'                                                                                                                       
        option _orig_bridge 'true'                                                                                                                           
        option proto 'dhcp'                                                                                                                                  
        option ifname 'eth0.102' 
...
--- >8 ---
--- 8< --- /etc/config/wireless
...
config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'La Bo[a]te Coworkers'
        option encryption 'psk2'
        option key 'xx'
        option network 'vlan101'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'La Bo[a]te Public'
        option encryption 'psk2'
        option key 'xx'
        option network 'vlan102'
...
--- >8 ---